topblog Ivoire blogs

22/03/2016

E-SYS changes manufacturing date to recode BMW module

As we all know, Zeitkriterium or manufacturing date is an important part of most retrofits that enables the use of Esys interface to recode a BMW module in order to activate the retrofit. And here, obdexpress guides you to change zeitkriterium or manufacturing date.

ENET-CABLE.jpg
For example, some F10 models came with halogen lights and most owners want to retrofit the LCI xenon headlights for better looks and visibility. The DRL is also very weak on halogen headlights and that ruins the way the car looks compared to the xenon equipped ones.

In this tutorial, we will show you how to do it step by step.

Connect to E-sys cable and choose your chassis

esys-change-manufaturing-date (1).jpg
Read FA and activate FA

esys-change-manufaturing-date (2).jpg
Click on Save and give the file any name you wish, then click on Edit. Right click on the FA and click Calculate FP.

esys-change-manufaturing-date (3).jpg
Edit the Zeitkriterium value accordingly to your needs

esys-change-manufaturing-date (4).jpg
Calculate FP again then save

esys-change-manufaturing-date (5).jpg
Go to the VCM tab, load the file and calculate FP again

esys-change-manufaturing-date (6).jpg
Select VCM Master and Write FA FP

esys-change-manufaturing-date (7).jpg
Now that the FA FP has been written to the car you can go ahead and recode your module by going back to the Expert Mode Coding tab, Read SVT to see the modules list, right click on the module name (Ex: FRM) and click on “Code”.
Wait for the process to finish and you`re done!

07:11 Publié dans Blog, Shopping, Web | Lien permanent | Commentaires (0)

21/03/2016

Tech 2 TIS2000 Cannot Connect with Error 666 (SOLVED)

Tried to do SPS/TIS programming, etc. with my GM Tech 2 scanner. But I cant get it to work when i connected to my PC with windows XP system! Stupid serial ports, I don’t know why GM has not made the Tech 2 USB yet. Most computers don’t even come with legacy ports anymore.

It’s almost as if the Tech 2 knows the PC is there, but the PC doesn’t know the Tech 2 is there. Because when I plug it in and turn on the Tech 2, it says "waiting for download" for a second on the tech 2 screen. When I try to connect with the PC, it hangs for a second then says "cannot connect".

Surfed the Internet and read many posts.

And finally found that there is a setting that is kind of hard to find that will set COM port.

It's under CONFIGURATION>I/O MANAGEMENT>TECH2>PROPERTIES.

Normal TIS2000 software that comes with it requires a USB security dongle. Go figure. TIS2000 is COM yet the security is USB. This REALLY screws up things sometimes.

If you do need the dongle and don't have one, it will error with:

E666: Access to Service Programming Server was denied.

tech2-tis200-error-E666-1.jpg

tech2-tis200-error-E666-2.jpg

I happened to meet with this issue before. This can also mean it doesn't "see" the dongle, and you forgot to install the dongle driver.

06:54 Publié dans Blog, Shopping, Web | Lien permanent | Commentaires (0)

18/03/2016

Mangoose Reflash Gearbox ECM on a Jaguar 2003 S-Type

Here’s my experience of Jaguar 2003 S-Type R. this review is to thanks solutions from forum brothers, especially Bob (That bulletin was great). I have succeeded to reflash the gearbox and program the TCM to address the P0610 code. And now the car is running. See my in-depth report later.

Model:
Jaguar 2003 S-Type R (4.2L supercharged)

Tools used:
Mongoose JLR with SAE J2534
(this tool nowadays seems not for JLR before 2005)

Background information:
I reflashed the ECM and TCM wanting to have the latest calibrations in each (the ECM to possibly help with the lean codes, and the TCM with an eye to running the trans adaption routine to fix a shift quality issue). Upon trying to restart the car I find that the car won’t start.

After trying to reflash and run the immobilisation routine we concluded that the ECM must be dead. We installed a used ECM, ran the immobilisation routine and viola the car started and ran. The message display center indicated a gearbox fault. Upon further investigation a P0610 was found indicating the wrong configuration file was loaded in the TCM. We successfully reflashed the used ECM with new firmware using the "Configure Existing Modules" routine in IDS. The car started after doing this. The only glitch is that when we read the list of modules in the car the ECM reported the VIN from the car it came out of. We re-read the description listed under "Configure New Modules" and decided to try this. To make a long story short, after erroring out, we have ended up with another unresponsive engine controller.

SOLUTION:
I read the bulletin 1-186 Using WDS To Program_Configure.pdf - Great stuff in here, confirming some of my suspicions about the VID block.

Re-installed the original ECM. Then checked the VID block - no communications with the ECM.

Started the IDS/SDD 128 session with my Mongoose JLR with SAE J2534 disconnected from the vehicle.

Then I input the full 17 digit VIN and hit enter, based on the VIN it initiated a Legacy IDS session.

Answered NO to the question, "do you wish to read the configuration from the vehicle", this forced IDS to retrieve the "as built" VID from the hard drive (a tip I garnered from the info in the bulletin).

Checked the descriptions listed for equipment level and accepted them as correct.

IDS then prompted to read DTCs - answered NO.

Connected the IDS/Mongoose JLR to the car.

Now with a charger connected to the car set for 13.0V

Initiated a "Configure Existing Module" routine and selected the Engine Controller.

Followed the prompts until communication failed out

IDS eventually prompted the "Rectification Procedure".

Now I have performed this rectification procedure on this module before with no joy, but thanks to the bulletin when the time came to disconnect the negative battery cable I shorted together the two cables while they were disconnected.

After the prompt to reconnect, I followed the onscreen prompts as presented and ended up with a reported successful reflash! Still no start though, so I initiated the "Immobilisation Reset", and viola the car fired up!

Next, I initiated the report on all the vehicle control modules and happily the ECM was reorting the correct VIN. You have no idea how happy that made me!

I then successfully programmed the TCM to address the P0610 code. All I need to do now is perform the Transmission Adaption Routine.

I then repeated the ECM Reflash/Rectification routine on the other locked ECM, and successfully recovered that one too!

So, in closing, I learned that the VID block is very important to get right. That connecting the cables together during the disconnect portion of the "ECM Rectification" is necessary to succeed. Finally I learned never to flash a Transmission Control Module when the VID stored in the ECM is incorrect!

I hope my summary makes good reading!

04:46 Publié dans Blog, Shopping, Web | Lien permanent | Commentaires (0)