topblog Ivoire blogs

16/11/2016

How to solve Kess v2 ksuite “Protocol not compatible”

Here is a customer solution of Kess V2 Ksuite v2.22 protocol error “Protocol not compatible with version FW”. Put it for sharing. Wish it helps anyone.

 

The customer bought SE87-C (kess v2 master v4.036 ksuite v2.22).
He got the error message“Protocol not compatible with version FW.”when trying to read a Audi 2,0tdi 2007 BRD engine. Ecu: Siemens PPD1.3 I
I have test software version 2.06-2.22 same problem.

kess-v2-ksuite-v2-22-protocol-error-1 kess-v2-ksuite-v2-22-protocol-error-2

Then the customer have successfully solved the Kess v2 protocol error himself.

 

He said as below:

kess-v2-protocol-error-solution

 

“I have solved the protocol error myself.
Here is how: I installed the ksuite 2.06 full, then copy the ksuite 2.08 who is in the token reset folder that has the firmware's in update folder into my install directory. (like you do in the video for the ksuite 2.08)”

 

 

(BIG thanks to Konstantinos Raptis)

 

15/11/2016

(solved) Vocom + Tech Tool view DTCs of MACK truck

I'm have a MACK to read faults, but unluckily I failed to diagnose (view DTC's) or use any off the other features of my Tech Tool 2.04.87. PTT says the software is incompatible and that version on the control unit(s) is not supported by Tech Tool.

Here is my version info:

Product: Tech Tool
Version: 2.04.87
Database: Standard

Last updated: APCI (-A) 11/8/2016 12:19:36 PM
Last updated: APCI+ (-A) 9/14/2016 1:56:29 PM

Every time I go to view DTC's I get these errors :
it says: the version of software installed in the engine and vehicle electronic control units are incompatible. Electrical faults will present in one or both modules. Upgrade the software in one or both modules to correct the problem.

tech-tool-version-incompatible

then i Click OK and get this one:

Software on the control unit(s) below is not supported by Tech Tool.

Please update Tech Tool and try again.

144 144

software-not-supported-by-tech-tool

Then ask obd2express for help.. solved my issue

I am advised to update the firmware of 88890300 Vocom Interface. Just follow the screen message to do that. Then tech tool works like a charm.

BIG thanks to http://www.obdexpress.co.uk/

14/11/2016

Kess V2 Bench cable or OBD cable, which for MB temic truck cables?

Any doubts about MB temic cables for Kess v2 tuning work? Bench cable or OBD cable?

There are some differences between the bench cable 144300K249 and the obd2 cable 144300K251:

 

You can not clone ecu from obd, for that you need bench cable.
Old boot cable works only on boot mode and does not support new continental ecu without flash memory.

 

So buy just two head (round + obd) Temic truck cable (with part number 144300K249). That is your choice for tuning.

 

 

This cable has been done on 200-300 MB trucks by a user, first in boot mode and after Kess v2 released OBD protocol.
Never had really any problems.

 

It’s easy to find with Google search seller from China sellers or other who sell euro clone Kess v2 or Ktag
But you have no this ecu tool now. Better to buy a Kess v2 truck version. It is a truck specialized version. Compared with other kess in markets, this truck version adds a lot of ECUs for trucks diagnosis and ecu programming.

 

Kess v2 truck tuning kit price: €64

Version: software V2.08/V2.22, firmware V4.024

Kess v2 car list (truck):

http://www.obdexpress.co.uk/upload/pro/kess-v2-supported-...

truck-kess-v2

Mercedes ECUs ok with Kess v2 truck:

kess-v2-mercedes-truck-list-1 kess-v2-mercedes-truck-list-2 kess-v2-mercedes-truck-list-3

 Kess v2 boot cables

kess-v2-truck-boot-cable

Kess v2 obd cable:

kess-v2-obd-cable

Other kess v2 cables for truck tuning:

 

kess-v2-truck-cable-1 kess-v2-truck-cable-2 kess-v2-truck-cable-3 kess-v2-truck-cable-4 kess-v2-truck-cable-5

Kess truck full info:

http://www.obdexpress.co.uk/wholesale/truck-kess-v2-firmw...

 


This article is from:http://blog.obdexpress.co.uk/2016/11/14/which-kess-v2-mb-...