topblog Ivoire blogs

14/06/2019

How restall XS evolution Lexia probe On Windows 7

Here is the user experience of lexia3 PP2000 scanner ,about how to upgrade XS evolution Lexia probe On Windows 7

 

Here you are:

I have a probe XS evolution acquired in 2009 clone version Normal (not full chip, see photos attached) that had been delivered with the LEXIA software version 345.13.

I used it for several years and even upgraded to V346.01 (by mistake) from the Citroen server on a PC that was running on XP.

I no longer have a PC in XP, this probe has always brought me satisfaction, so I want to proceed to a soft re-installation on a PC dedicated to the diag and who has already can clip, PC running Windows 7 32 Bits,

– My Lexia 345.13 soft distribution certainly does not turn on windows 7, should I install Diagbox?

– Can my old probe work with recent versions of diagbox?

– Can there be a problem of firmware version, firmware / diagbox incompatibility?

– I have no idea of ​​the firmware version of the probe that I have, How can I identify it?

 

Finally.

I have now completed the installation of Diagbox 7.02, the installation proceeded normally according to the detailed procedure here

 

Small comment at the end of the installation of diagbox 7.02, the directory C: APPLI containing the PSA Interface Checker had disappeared without explanation.

At the first launch of Diagbox, updates were made automatically and the firmware of the probe was also updated.

A first attempt of DIAG does not point out any error and obliges me to manually enter a number of OR and a VIN.

Bizu Diagbox (I used the Lexia GUI) it seems to me that the VIN should read automatically in Lexia, also not knowing my VIN, I did not try to go beyond judging the abnormal situation.

I tried to run Scantools rather than Lexia and my interface is declared not properly initialized, message “The communication card has not started correctly, It is necessary to restart the tool”

Anxious about the operation of the VCI I reloaded PSA Interface Checker to confirm that it has been updated, it is still recognized as “ACTIA USB Device – USB Com Board Driver (Multi Instance)” in the device manager , The version of the interface is now “APPLI_XS_Fuji_P106138A V4.3.0 @ACTIA 02.01.12”

– Do I have 2 left hands not knowing how to use Diagbox to run a LEXIA diag and read the VIN?

or

– Should I fear a VCI probe incompatibility problem with Diagbox?

or

– A problem with the operation of the new firmware or incorrect loading?

According to the excellent post

 

it seems to me that a V4.3.0 should work with Diagbox 7.0.2 so not a problem of incompatibility, and even if this probe remains a version B it should work without requiring flashing version C XS Evolution.

I want to add that the diag test was done on the same vehicle as before the migration and that my VCI was in perfect working order before migration on Windows 7 + Diagbox + Update firmware probe. I unfortunately cannot afford to check it to remove the doubt of a hardware pb,

Another observation that may be important. PSA Interface Search in serial number: “963830 B /” followed by several spaces and end of line “PEUGEOT”.

Could it be that I do not have serial number on this probe?

 

Question followed:

As you have been advised above: You have to change the bootloader (and at the same time the serial content in the SPI) of your microphone so that the probe is recognized with an “evolving” driver: for that two methods is that of nlc is the direct flash by the 2x6pts connector on the micro card (and the universal programmer for the SPI)

For the first method: you have to find (on the web) the firmware of nlc non nominatif …. hush !!!!!

For the second method: you have to find the file of the microphone and that of the SPI as well as a prog for the microphone MB90F and a universal prog for the SPI (to unsolder or to flash on card with a clip SOIC).

That’s for short … it will allow you to remove any doubt about a compatibility problem with DIAGBOX and then lean on a possible hardware problem.

 

Answer:

Thanks for this confirmation of the only issue and need to migrate in evolution mode with upgrade bootloader and SN.

Not that I do not feel like implementing the Hard N ° 2 method that you describe, the solution N ° 1 NLC mode seems much faster to implement with a risk of success rate reduced, I will continue this way.

FYI, however, I managed to run my VCI and lead a diag by forcing the firmware in V4.2.4 (prior to V4.2.8) and prohibiting diagbox 7.02 update the firmware of the probe at startup.

The VIN is then recognized and LEXIA turns for diagnosis.

The stability of communication does not seem at the top, however, I had crashes that I attribute to a situation a little wobbly from a point of view coherence between USB driver of the VCI (bootloader), the Firwmare V4.2.4 and not V4.3.0 as expected by Diagbox 7.0.2, however, I can not consider this situation as stable.

At Minima it gives me the indication that my hardware is OK.

 

Credits to @barsailer from http://www.lemondedudiagauto.com

 

Thanks to Laurance for collecting this info.

 

PP2000/Lexia-3 Interface